SaaS版 prev_link、next_linkが表示されない

マニュアルへの追加要望や内容の間違い報告など

SaaS版 prev_link、next_linkが表示されない

投稿記事by selectfarm on 2009年2月04日(水) 20:39

SaaS版を使っています。

公式HPのマニュアルには、ブログトップページで
prev_link、next_linkのブロックが使用可能とありますが、このブロックを打っても何も表示されません。

SaaS版ではこのブロックは使用できないのでしょうか?
または、トップページでは使用できないのでしょうか?
selectfarm
 
記事: 16
登録日時: 2009年2月01日(日) 19:19

Re: SaaS版 prev_link、next_linkが表示されない

投稿記事by okada on 2009年2月04日(水) 22:08

こんばんは、okadaです。

デモサイトでは使えているので使えるはずです。
ブログを新規作成したときのテンプレートを参考に、今一度テンプレートを確かめてみてください。

それでも解決しないときはテンプレートの該当箇所を載せてください。

ではでは。

(バグではないと思いますので「バグ報告」から移動しました。)
okada@株式会社日本情報化農業研究所

SOY CMS http://www.soycms.net/
SOY Shop http://www.soyshop.net/
SOY App http://www.soycms.net/extentions
開発ブログ http://www.soycms.net/blog/
Twitter http://twitter.com/SOY_CMS
okada
 
記事: 553
登録日時: 2008年6月07日(土) 00:49

Re: SaaS版 prev_link、next_linkが表示されない

投稿記事by selectfarm on 2009年2月05日(木) 01:20

ブログトップのテンプレートは以下の通りです。

<div b_block:id="entry_list">

</div b_block:id="entry_list">

<p>
<a b_block:id="prev_link"></a>
<a b_block:id="next_link"></a>
</p>

よろしくお願いします。
selectfarm
 
記事: 16
登録日時: 2009年2月01日(日) 19:19

Re: SaaS版 prev_link、next_linkが表示されない

投稿記事by okada on 2009年2月05日(木) 14:50

(移動先を間違えた…)

その書き方だとリンクを張る文字がないので何も表示されてはいないだけでは?
出力されたHTMLソースを見てもらえれば次のページと前のページへのURLがhrefの値に入っているのが分かると思います。
間違っていたらすみません。

ちなみにブログを新規作成したときのテンプレートは
コード: 全て選択
<div class="navi">
<a b_block:id="prev_link">&lt;&lt;</a>
<a b_block:id="top_link">TOP</a>
<a b_block:id="next_link">&gt;&gt;</a>
</div>

のようになっています。
okada@株式会社日本情報化農業研究所

SOY CMS http://www.soycms.net/
SOY Shop http://www.soyshop.net/
SOY App http://www.soycms.net/extentions
開発ブログ http://www.soycms.net/blog/
Twitter http://twitter.com/SOY_CMS
okada
 
記事: 553
登録日時: 2008年6月07日(土) 00:49

Re: SaaS版 prev_link、next_linkが表示されない

投稿記事by selectfarm on 2009年2月08日(日) 20:11

リンクを張る文字を入れると解決しました。
初歩的なミスで申し訳ありません。

丁寧に対応していただき、ありがとうございました。
selectfarm
 
記事: 16
登録日時: 2009年2月01日(日) 19:19


Return to マニュアルについて

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]

cron