SOY CMSバージョンアップの際のPHPバージョンの変更について

インストール後の運用中に生じた質問などはこちら。
管理画面の操作方法でわからないところやTipsなども

SOY CMSバージョンアップの際のPHPバージョンの変更について

投稿記事by designlog on 2019年11月12日(火) 13:00

いつもお世話になっております。

現在SOY CMS1.5.0(Sqlite)がPHP5.2.8で稼働しているサイトがあり、3.0.2p184にバージョンアップしようとしているのですが、その際にPHP7.1.15に変更しようとしています。
念の為、1.5→1.6→1.7→1.8.15→1.8.15p7.24→3.0.2p184と、0.1ずつ刻んでバージョンアップする手順で考えていますが、どのタイミングでPHPのバージョン変更するのがベストかご教示いただけると助かります。
(SOYのバージョンアップは各バージョンで動作を確認しながら連続で行います)
designlog
 
記事: 104
登録日時: 2010年1月11日(月) 16:42

Re: SOY CMSバージョンアップの際のPHPバージョンの変更について

投稿記事by inunosinsi on 2019年11月13日(水) 06:38

PHP7にするのは1.8.15p7.24からが良いです。
可能であれば、1.8.15p7.24でPHP7.0系にして、3系でPHP7.2か7.3にすると良いです。
大阪でフリーのプログラマをしています。
以前はSOY CMSの開発元で働いていました。

SOY ShopのプラグインやSOY Appの開発のサポートをしています。
http://saitodev.co/soycms(SOY CMSのマニュアルを作成しています)

最近はSOY Shopを業務アプリとして使用できないか?と模索しています。
SOY Shopで管理画面のみ使用モードを追加しました - saitodev.co

株式会社京都農販(SOY Shopのサイト)
株式会社コトブキ園(SOY Shop)
inunosinsi
 
記事: 834
登録日時: 2008年6月12日(木) 20:48

Re: SOY CMSバージョンアップの際のPHPバージョンの変更について

投稿記事by designlog on 2019年11月13日(水) 11:11

ご返答いただきありがとうございました!

公式バージョンの1.8.15まではPHP7に未対応ということですね。
3系でPHP7.2か7.3にすると良いです。
とのアドバイスでしたが残念ながらサーバーが7.1.15までしか現状対応していないので、ひとまず7.1.15で運用しようと思います。
designlog
 
記事: 104
登録日時: 2010年1月11日(月) 16:42


Return to 運用・操作方法

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[3人]

cron