ページ 11

SOY CMSバージョンアップの際のPHPバージョンの変更について

投稿記事Posted: 2019年11月12日(火) 13:00
by designlog
いつもお世話になっております。

現在SOY CMS1.5.0(Sqlite)がPHP5.2.8で稼働しているサイトがあり、3.0.2p184にバージョンアップしようとしているのですが、その際にPHP7.1.15に変更しようとしています。
念の為、1.5→1.6→1.7→1.8.15→1.8.15p7.24→3.0.2p184と、0.1ずつ刻んでバージョンアップする手順で考えていますが、どのタイミングでPHPのバージョン変更するのがベストかご教示いただけると助かります。
(SOYのバージョンアップは各バージョンで動作を確認しながら連続で行います)

Re: SOY CMSバージョンアップの際のPHPバージョンの変更について

投稿記事Posted: 2019年11月13日(水) 06:38
by inunosinsi
PHP7にするのは1.8.15p7.24からが良いです。
可能であれば、1.8.15p7.24でPHP7.0系にして、3系でPHP7.2か7.3にすると良いです。

Re: SOY CMSバージョンアップの際のPHPバージョンの変更について

投稿記事Posted: 2019年11月13日(水) 11:11
by designlog
ご返答いただきありがとうございました!

公式バージョンの1.8.15まではPHP7に未対応ということですね。
3系でPHP7.2か7.3にすると良いです。
とのアドバイスでしたが残念ながらサーバーが7.1.15までしか現状対応していないので、ひとまず7.1.15で運用しようと思います。